文章 ID: 000058220 內容類型: 錯誤訊息 最近查看日期: 2022 年 07 月 28 日

使用智慧邊緣使用者介面控制器套用拓撲時發生錯誤

環境

YAMLTopologySmart Edge UI 控制器

BUILT IN - ARTICLE INTRO SECOND COMPONENT
摘要

如何解決在套用拓撲到 UI 控制器後可能發生的 YAML 檔案配置錯誤。

描述

當嘗試從拓撲中刪除應用程式時,會發生此問題。

解決方法
  1. 按一下拓撲頁面上的進口/出口按鈕,啟 YAML 組態
  2. 複製儲存 檔案
  3. 檢查 檔案中可能出現錯誤的原因:
    • 所部署的所有應用程式從包含所有應用程式資訊的應用程式開始
    • 所有連線從 kni 開始-
    • 這顯示了連線的虛擬連結,以及對應用程式的綁定。如果其中任一遺失或損壞,則套用將會失效。
  4. 刪除 不正確的 YAML 檔案部分。
  5. 按一下拓撲頁面上的套用/重設按鈕,重設拓撲。
  6. 重設完成後, 開啟 YAML 組態,然後用經過編輯的配置 替換 預設組態。
  7. 套用 YAML。
額外資訊

拓撲變更時,必須將變更套用在 UI 控制器中。拓撲變更的資訊在 YAML 檔案中,可從控制器進行檢查。如果這個檔案損壞,套用將會失敗。

這個頁面的內容綜合了英文原始內容的人工翻譯譯文與機器翻譯譯文。本內容是基於一般資訊目的,方便您參考而提供,不應視同完整或準確的內容。如果這個頁面的英文版與譯文之間發生任何牴觸,將受英文版規範及管轄。 查看這個頁面的英文版。